Knowledge Base

Ask A Question



La console reste en mode console

Je viens d'installer Rapid7 Security console de Nexpose sur un serveur sous Windows Server 2012 R2, quand je lance la console depuis le lien https://localhost:3780 et je me logue je reçois le message suivant (VM has reported the following error:Critical error during initialization: null). Durant l'instalation un fichier nommé error est généré sur le bureau du VM, ci-dessous son contenu. In action "nexserv.ico [Run script]" (screen "CustomInstallationScreen"), property "Script": C:\Program Files\rapid7\nexpose\nsc\nexserv.ico (Accès refusé) at Method) at at<init>( at<init>( at com.exe4j.runtime.util.FileUtil.copyFile( at com.install4j.script.I4jScript_Internal_157.eval( at com.install4j.script.I4jScript_Internal_157.evaluate(*29) at com.install4j.runtime.installer.helper.Script.evaluate( at com.install4j.runtime.installer.ContextImpl.runScript( at com.install4j.runtime.installer.ContextImpl.runScript( at com.install4j.runtime.beans.actions.control.RunScriptAction.execute( at com.install4j.runtime.beans.actions.SystemInstallOrUninstallAction.install( at com.install4j.runtime.installer.ContextImpl$7.executeAction( at com.install4j.runtime.installer.ContextImpl$7.fetchValue( at com.install4j.runtime.installer.ContextImpl$7.fetchValue( at com.install4j.runtime.installer.helper.comm.actions.FetchObjectAction.execute( at com.install4j.runtime.installer.helper.comm.HelperCommunication.executeActionDirect( at com.install4j.runtime.installer.helper.comm.HelperCommunication.executeActionInt( at com.install4j.runtime.installer.helper.comm.HelperCommunication.executeActionChecked( at com.install4j.runtime.installer.helper.comm.HelperCommunication.fetchObjectChecked( at com.install4j.runtime.installer.ContextImpl.performActionIntStatic( at com.install4j.runtime.installer.InstallerContextImpl.performActionInt( at com.install4j.runtime.installer.ContextImpl.performAction( at com.install4j.runtime.installer.controller.Controller.executeAction( at com.install4j.runtime.installer.controller.Controller.executeActions( at com.install4j.runtime.installer.controller.Controller.executeActionGroup( at com.install4j.runtime.installer.controller.Controller.executeActions( at com.install4j.runtime.installer.controller.Controller.handleCommand( at com.install4j.runtime.installer.controller.Controller.start( at com.install4j.runtime.installer.Installer.runInProcess( at com.install4j.runtime.installer.Installer.main( at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke( at sun.reflect.DelegatingMethodAccessorImpl.invoke( at java.lang.reflect.Method.invoke( at com.exe4j.runtime.LauncherEngine.launch( at com.exe4j.runtime.WinLauncher.main( at com.install4j.runtime.launcher.WinLauncher.main(

Posted by Walid Daidai about a year ago


Reverse shell over WAN

Hey all, I've been playing around with the reverse http payloads on my Kali machine. Now inside the LAN I've configured them all good, everything's very simple. However when configuring the payload to work over WAN, I've configured as following : On the payload itself : Lhost - Public IP (The WAN leg of my router) Lport - My external port On the handler itself : Lhost - Private IP (The IP of the kali machine at the router's internal LAN interface range) Lport - Same as my external port, though it makes no difference since I'm using port forwarding and can set it to whatever I like. On the router I've configured forwarding from the external port to the handler's IP and port configured. I've done port forwarding to another server in my LAN, and it works great for the past few months. If I use the reverse shell on a workstation inside the LAN (For example, even though the payload sends the shell to the router WAN leg (72.x.x.x) it still reaches the handler ( However when attempting to do so from outside the LAN, nothing happens. For testing purposes I've put up an apache service on the kali machine, set it up and made it accessible from the LAN. Set up port forwarding to it, and tested accessing it from the public IP. When I've tried from the LAN, it worked. But when attempting to access it from the WAN, the browser says the response took too long, behaving like the packet got dropped from a firewall. This behavior sounds more related to the specific Kali machine I'm using, however I've disabled it's firewall (Which it didn't have to begin with, downloaded ufw and then disabled it lol). TL;DR My Kali machine responds to requests sent to the WAN IP if being requested from a LAN station, but does not respond to requests sent to the WAN IP from a WAN station. Will appreciate any attempt to help!

Posted by Yigal van Dongen about a year ago